Cмотреть на GitHub

Загрузка

Загрузите Bootstrap, чтобы получить скомпилированные CSS и JavaScript, исходный код или включить его в свои любимые менеджеры пакетов, такие как npm, RubyGems и другие.

Скомпилированные CSS и JS

Загрузите готовый к использованию скомпилированный код для Bootstrap v4.6.0, чтобы его можно было легко использовать в вашем проекте, который включает:

Сюда не входят документация, исходные файлы или любые дополнительные зависимости JavaScript (jQuery и Popper).

Скачать

Исходные файлы

Скомпилируйте Bootstrap с вашим собственным конвейером ресурсов, загрузив наши исходные файлы Sass, JavaScript и документации. Этот вариант требует дополнительных инструментов:

Инструменты сборки также могут понадобиться при работе с Bootstrap, но все-таки они не совсем подходят для ваших целей.

Скачать исходники

Примеры

Если вам интересны наши примеры, то вы можете скачать их одним архивом:

Скачать примеры

jsDelivr

Пропустите загрузку с помощью jsDelivr чтобы получить кэшированную версию скомпилированных в Bootstrap файлов CSS и JS для «облегчения» страницы и ускорения загрузки.

<link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/bootstrap@4.6.0/dist/css/bootstrap.min.css" integrity="sha384-B0vP5xmATw1+K9KRQjQERJvTumQW0nPEzvF6L/Z6nronJ3oUOFUFpCjEUQouq2+l" crossorigin="anonymous">
<script src="https://cdn.jsdelivr.net/npm/bootstrap@4.6.0/dist/js/bootstrap.bundle.min.js" integrity="sha384-Piv4xVNRyMGpqkS2by6br4gNJ7DXjqk09RmUpJ8jgGtD7zP9yug3goQfGII0yAns" crossorigin="anonymous"></script>

Если вы используете наш скомпилированный JavaScript и предпочитаете включать Popper отдельно, добавьте Popper перед нашим JS, желательно через CDN.

<script src="https://code.jquery.com/jquery-3.5.1.slim.min.js" integrity="sha384-DfXdz2htPH0lsSSs5nCTpuj/zy4C+OGpamoFVy38MVBnE+IbbVYUew+OrCXaRkfj" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/popper.js@1.16.1/dist/umd/popper.min.js" integrity="sha384-9/reFTGAW83EW2RDu2S0VKaIzap3H66lZH81PoYlFhbGU+6BZp6G7niu735Sk7lN" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/bootstrap@4.6.0/dist/js/bootstrap.min.js" integrity="sha384-+YQ4JLhjyBLPDQt//I+STsc9iw4uQqACwlvpslubQzn4u2UU2UFM80nGisd026JF" crossorigin="anonymous"></script>

Системы управления пакетами (Хождение по сайтам библиотек, скачивание и распаковка архивов, копирование файлов в проект — всё это заменяется парой команд в терминале)

Используйте исходники Bootstrap в любом проекте с помощью популярных систем управления пакетами. С любой системой управления пакетами Bootstrap потребует компилятор Sass (препроцессор) и постпроцессор для правильной установки наших компилированных версий.

npm

Установите Bootstrap в свои приложения, работающие на Node.js, с помощью пакета npm:

npm install bootstrap

require('bootstrap') загрузит все плагины jQuery Bootstrap в объект jQuery. Сам модуль bootstrap ничего не экспортирует. Вы можете вручную загрузить плагины jQuery для Bootstrap по отдельности, загрузив файлы /js/*.js в каталог верхнего уровня пакета.

Bootstrap package.json содержит некоторые дополнительные метаданные под следующими ключами:

  • sass - путь к основному исходному файлу Bootstrap Sass
  • style - путь к неминифицированному CSS Bootstrap, который был предварительно скомпилирован с использованием настроек по умолчанию (без настройки)
Начните работу с Bootstrap через npm с помощью нашего начального проекта! Перейдите в репозиторий шаблонов twbs/bootstrap-npm-starter, чтобы узнать, как создать и настроить Bootstrap в своем собственном проекте npm. Включает компилятор Sass, Autoprefixer, Stylelint, PurgeCSS и иконки Bootstrap.

yarn

Установите Bootstrap в свои приложения на Node.js с пакетом yarn:

yarn add bootstrap

RubyGems

Устанавливайте Bootstrap в ваши приложения на Ruby с помощью Bundler (рекомендовано) и системы управления пакетами «RubyGems», просто добавив следующую строку в ваш Gemfile:

gem 'bootstrap', '~> 4.6.0'

Еще один способ – если вы не используете Bundler, вы можете установить gem-файл такой командой:

gem install bootstrap -v 4.6.0

Смотри gem’s README.

Composer

Вы также можете установить и управлять Sass и JavaScript для Bootstrap, используя Composer:

composer require twbs/bootstrap:4.6.0

NuGet

Если Вы разрабатываете в .NET, Вы также можете установить и управлять Bootstrap CSS или Sass и JavaScript используя NuGet:

Install-Package bootstrap
Install-Package bootstrap.sass